<!DOCTYPE html>
<html lang="en-US" xmlns:fb="http://ogp.me/ns/fb#" xmlns:addthis="http://www.addthis.com/help/api-spec"  prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#">
<head>
	<meta charset="UTF-8">
	<meta name="viewport" content="width=device-width, initial-scale=1">
	<link rel="profile" href="http://gmpg.org/xfn/11">
	<link rel="pingback" href="http://blogs.kcrw.com/music/xmlrpc.php">

	<title>Music For Your Weekend | KCRW Music Blog</title>

<!-- This site is optimized with the Yoast SEO plugin v5.0.1 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="KCRW&#039;s Music Blog! Providing the best new music, artists you should know, and exclusive content, at KCRW.com"/>
<link rel="canonical" href="http://blogs.kcrw.com/music/2017/07/music-for-your-weekend-16/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Music For Your Weekend | KCRW Music Blog" />
<meta property="og:description" content="KCRW&#039;s Music Blog! Providing the best new music, artists you should know, and exclusive content, at KCRW.com" />
<meta property="og:url" content="http://blogs.kcrw.com/music/2017/07/music-for-your-weekend-16/" />
<meta property="og:site_name" content="KCRW Music" />
<meta property="article:publisher" content="https://www.facebook.com/kcrwradio" />
<meta property="article:section" content="Best New Music" />
<meta property="article:published_time" content="2017-07-07T10:59:44-07:00" />
<meta property="article:modified_time" content="2017-07-07T17:09:29-07:00" />
<meta property="og:updated_time" content="2017-07-07T17:09:29-07:00" />
<meta property="fb:admins" content="40098658" />
<meta property="og:image" content="http://blogs.kcrw.com/music/wp-content/uploads/2017/07/toro-y-moi-grass.jpg" />
<meta property="og:image:width" content="1280" />
<meta property="og:image:height" content="720" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="KCRW&#039;s Music Blog! Providing the best new music, artists you should know, and exclusive content, at KCRW.com" />
<meta name="twitter:title" content="Music For Your Weekend | KCRW Music Blog" />
<meta name="twitter:site" content="@kcrw" />
<meta name="twitter:image" content="http://blogs.kcrw.com/music/wp-content/uploads/2017/07/toro-y-moi-grass.jpg" />
<meta name="twitter:creator" content="@itsabyrd" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="KCRW Music &raquo; Feed" href="http://blogs.kcrw.com/music/feed/" />

		<meta property="og:title" content="Music For Your Weekend"/>
		<meta property="og:description" content=""/>
		<meta property="og:type" content="article"/>
		<meta property="og:url" content="http://blogs.kcrw.com/music/2017/07/music-for-your-weekend-16/"/>
		<meta property="og:site_name" content="KCRW Music"/>
					<meta property="og:image" content="http://blogs.kcrw.com/music/wp-content/uploads/2017/07/toro-y-moi-grass-1024x576.jpg"/>
		
				<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/blogs.kcrw.com\/music\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b===c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='igw-fancybox-stylesheet-css'  href='http://blogs.kcrw.com/music/wp-content/plugins/instagram-gallery-widget/lib/fancybox/jquery.fancybox-1.3.4.css?ver=4.8' type='text/css' media='all' />
<link rel='stylesheet' id='crp-style-rounded-thumbs-css'  href='http://blogs.kcrw.com/music/wp-content/plugins/contextual-related-posts/css/default-style.css?ver=4.8' type='text/css' media='all' />
<style id='crp-style-rounded-thumbs-inline-css' type='text/css'>

.crp_related a {
  width: 150px;
  height: 150px;
  text-decoration: none;
}
.crp_related img {
  max-width: 150px;
  margin: auto;
}
.crp_related .crp_title {
  width: 150px;
}
                
</style>
<link rel='stylesheet' id='kcrw-migrate-css'  href='http://blogs.kcrw.com/music/wp-content/plugins/kcrw-migrate/public/css/kcrw-migrate-public.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='popup-maker-site-css'  href='http://blogs.kcrw.com/music/wp-content/plugins/popup-maker/assets/css/site.min.css?ver=1.6.3' type='text/css' media='all' />
<link rel='stylesheet' id='parent-style-css'  href='http://blogs.kcrw.com/music/wp-content/themes/kcrw-triplicity/style.css?ver=4.8' type='text/css' media='all' />
<link rel='stylesheet' id='child-style-css'  href='http://blogs.kcrw.com/music/wp-content/themes/musicblog/style.css?ver=4.8' type='text/css' media='all' />
<link rel='stylesheet' id='featured-posts-css'  href='http://blogs.kcrw.com/music/wp-content/themes/musicblog/css/music_blog.css?ver=1.4' type='text/css' media='all' />
<link rel='stylesheet' id='kcrw-triplicity-style-css'  href='http://blogs.kcrw.com/music/wp-content/themes/musicblog/style.css?ver=1.5' type='text/css' media='all' />
<script type='text/javascript' src='http://blogs.kcrw.com/music/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://blogs.kcrw.com/music/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://blogs.kcrw.com/music/wp-content/plugins/instagram-gallery-widget/js/igw-frontend-init.js?ver=4.8'></script>
<script type='text/javascript' src='http://blogs.kcrw.com/music/wp-content/plugins/instagram-gallery-widget/lib/fancybox/jquery.fancybox-1.3.4.pack.js?ver=4.8'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var kcrw = {"ajaxUrl":"https:\/\/blogs.kcrw.com\/music\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://blogs.kcrw.com/music/wp-content/plugins/kcrw-blog-toolset/assets/js/popular_tracking.js?ver=1.0'></script>
<script type='text/javascript' src='http://blogs.kcrw.com/music/wp-content/plugins/kcrw-migrate/public/js/kcrw-migrate-public.js?ver=1.0.0'></script>
<link rel='https://api.w.org/' href='http://blogs.kcrw.com/music/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://blogs.kcrw.com/music/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://blogs.kcrw.com/music/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.8" />
<link rel='shortlink' href='http://blogs.kcrw.com/music/?p=52977' />
<link rel="alternate" type="application/json+oembed" href="http://blogs.kcrw.com/music/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fblogs.kcrw.com%2Fmusic%2F2017%2F07%2Fmusic-for-your-weekend-16%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://blogs.kcrw.com/music/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fblogs.kcrw.com%2Fmusic%2F2017%2F07%2Fmusic-for-your-weekend-16%2F&#038;format=xml" />
<style type="text/css" media="screen">
div.igw-widget-container {
	clear:both;
}

div#igw-gallery-header {
	margin           : 0px 0px 5px 0px;
	background       : url('http://blogs.kcrw.com/musicnews/wp-content/plugins/instagram-gallery-widget/images/icons/header-background.jpg') top repeat-x;
	padding          : 5px;
	font-family      : Arial, Verdana, sans-serif;
	height           : 65px;
}

div#igw-gallery-content {
	clear:both;
}

div#profile_picture_box {
	vertical-align : middle;
	margin         : 0px 10px 0px 0px;
	float          : left;
}

div#profile_userinfo_box {
	float: left;
}

h4#igw_profile_username {
	font-size   : 18px;
	color       : #FFFFFF;
	margin      : 1px 0px 5px 0px;
	font-family : Arial, Verdana, sans-serif;
}

div.igw_userinfo_block {
	float              : left;
	margin             : 0px 2px 0px 0px;
	color              : #FFFFFF;
	width              : 60px;
	text-align         : center;
	font-weight        : bold;
	box-shadow         : 2px 2px 2px #000000;
	-webkit-box-shadow : 2px 2px 2px #000000;
	-moz-box-shadow    : 2px 2px 2px #000000;
}

span.igw_userinfo_block_number {
	display                     : block;
	height                      : 15px;
	line-height                 : 16px;
	background-color            : #3a6899;
	padding                     : 2px;
	font-size                   : 15px;
	-moz-border-radius-topright : 4px;
	border-top-right-radius     : 4px;
	-moz-border-radius-topleft  : 4px;
	border-top-left-radius      : 4px;
	font-family                 : Arial, Verdana, sans-serif;
}

span.igw_userinfo_block_label {
	display                        : block;
	height                         : 15px;
	line-height                    : 12px;
	background-color               : #1f3d5c;
	padding                        : 2px;
	font-size                      : 11px;
	-moz-border-radius-bottomright : 4px;
	border-bottom-right-radius     : 4px;
	-moz-border-radius-bottomleft  : 4px;
	border-bottom-left-radius      : 4px;
	font-family                    : Arial, Verdana, sans-serif;
}

img.igw_thumb {}

a.igw_thumblink {
	float   : left;
	display : block;
	margin  : 0px 1px 0px 0px;
}</style><script>
	// If _gaq doesn't exist, create it so we avoid JS errors on the page (All blogs)
	var _gaq = _gaq || [];

	// Create a container for KCRW-specific data (All blogs)
	var kcrwTracking = {
		debug: false
	};

	// Track clicks on the main (eyebrow) navigation (All blogs, all pages)
	jQuery(function($){
		$('#header-cat-menu').on('click', 'a', function(e){
			if (kcrwTracking.debug) {
				e.preventDefault();
				console.log('Clicked on the main menu');
			}
			_gaq.push(['_trackEvent', 'Navigation', 'MainNavClick']);
		});
	});

	 // Only track these things on a single post view (all post types, all blogs)

		// Pull custom variables from PHP to JS, push to Google
		kcrwTracking.postId = '52977';
		kcrwTracking.postType = 'post';
		kcrwTracking.postCat = 'Best New Music';
		if (kcrwTracking.debug) {
			console.log('Post ID is ' + kcrwTracking.postId);
			console.log('Post type is ' + kcrwTracking.postType);
			console.log('Main category is ' + kcrwTracking.postCat);
		}
		_gaq.push(['_setCustomVar', 1, 'UID', kcrwTracking.postID, 3]);
		_gaq.push(['_setCustomVar', 2, 'portal_type', kcrwTracking.postType, 3]);
		_gaq.push(['_setCustomVar', 3, 'category', kcrwTracking.postCat, 3]);

		// Set up custom event tracking for scrolling to article bottom
		jQuery(function($){
			var pageTitle = document.title,
				articleContainer = $('.entry-content'),
				timer = 0,
				endContent = false,
				beginning = new Date(),
				startTime = beginning.getTime();

			// Track the scroll down the page and fire a Google Analytics event when the end of the article is reached
			function trackScroll(){
				var scrollPosition = $(window).height() + $(window).scrollTop(),
					articlePosition = articleContainer.position(),
					articleTop = articlePosition.top,
					articleHeight = articleContainer.innerHeight(),
					articleBottom = articleTop + articleHeight;

					if (scrollPosition - 100 >= articleBottom && !endContent) {
						var end = new Date(),
							endTime = end.getTime(),
							timeToContentEnd = Math.round((endTime - startTime) / 1000);
						if (kcrwTracking.debug) {
							console.log('Read to the end of the article!');
						}
						_gaq.push(['_trackEvent', 'Reading', 'ArticleEnd', '', timeToContentEnd]);
						endContent = true; //Make sure we only track the article end once
					}
			};

			// Buffer scroll tracking so we don't call it too often
			$(window).scroll(function(){
				if (timer) { clearTimeout(timer); }
				timer = setTimeout(trackScroll, 100);
			});
		});
	 // End of single post view only code

	// Add the custom data we're tracking to _gaq (All blogs)
	_gaq.push(['_setAccount', 'UA-404580-2']);
	_gaq.push(['_setDomainName', 'none']);
	_gaq.push(['_trackPageview']);

	// Include tracking JS file from Google (All blogs)
	(function() {
		var ga = document.createElement('script');
		ga.type = 'text/javascript';
		ga.async = true;
		ga.src = ('https:' == document.location.protocol ? 'https://' : 'http://') + 'stats.g.doubleclick.net/dc.js';
		var s = document.getElementsByTagName('script')[0];
		s.parentNode.insertBefore(ga, s);
	})();
</script><link rel="icon" href="http://blogs.kcrw.com/music/wp-content/uploads/2017/03/cropped-kcrw-favicon-2017-32x32.png" sizes="32x32" />
<link rel="icon" href="http://blogs.kcrw.com/music/wp-content/uploads/2017/03/cropped-kcrw-favicon-2017-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="http://blogs.kcrw.com/music/wp-content/uploads/2017/03/cropped-kcrw-favicon-2017-180x180.png" />
<meta name="msapplication-TileImage" content="http://blogs.kcrw.com/music/wp-content/uploads/2017/03/cropped-kcrw-favicon-2017-270x270.png" />
	<style id="pum-styles" type="text/css">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</style>
</head>

<!-- MOOG START -->

<!--
-->

<!-- MOOG END -->


<body class="post-template-default single single-post postid-52977 single-format-standard group-blog jsOff">
<div id="page" class="hfeed site">
	<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

	<header id="masthead" class="site-header" role="banner">
		<div class="site-header-wrap">
			<div class="site-nav">
				<a id="blog-menu-toggle" href="#blog-menu">Menu</a>
			</div>
			<div class="site-branding">
				
									<p class="site-title"><a href="http://blogs.kcrw.com/music/" rel="home">/Music</a></p>
							</div>
			<div class="site-search">
				<div id="header-cat-menu"></div>
				<a id="search-toggle" href="#blog-search">&nbsp;</a>
			</div>
		</div>
	</header>

			<div id="blog-menu">
			<h2>KCRW Blogs</h2>
			<ul>
														<li class="">
						<a href="http://blogs.kcrw.com/whichwayla/">
							For The Curious						</a>
					</li>
														<li class="">
						<a href="http://blogs.kcrw.com/musicnews/">
							Music Blog						</a>
					</li>
														<li class="">
						<a href="http://blogs.kcrw.com/goodfood/">
							Good Food						</a>
					</li>
														<li class="">
						<a href="http://blogs.kcrw.com/dna/">
							Design & Architecture						</a>
					</li>
														<li class="">
						<a href="http://blogs.kcrw.com/members/category/first-take">
							First Take						</a>
					</li>
														<li class="">
						<a href="http://blogs.kcrw.com/members/">
							Members						</a>
					</li>
														<li class="">
						<a href="http://blogs.kcrw.com/music/category/rhythm-planet/">
							Rhythm Planet						</a>
					</li>
														<li class="">
						<a href="http://blogs.kcrw.com/shortcuts/">
							Shortcuts						</a>
					</li>
														<li class="kcrw-link">
						<a href="http://www.kcrw.com">
							Return to KCRW.com						</a>
					</li>
							</ul>
		</div>

	
	
<div id="blog-search">
	<form role="search" method="get" class="search-form" action="http://blogs.kcrw.com/music/">
		<label>
			<span class="screen-reader-text">Search for:</span>
			<input type="search" class="search-field" placeholder="Search KCRW Music" value="" name="s" title="Search for:" />
		</label>
		<p class="search-help">Type and press enter</p>
	</form>
</div>

	
					<div id="content" class="site-content">
	
	<div id="primary" class="content-area">
		<main id="main" class="site-main" role="main">

		
			
<article id="post-52977" class="post-52977 post type-post status-publish format-standard has-post-thumbnail hentry category-best-new-music category-carousel">
	<header class="entry-header">
					<div class="entry-thumb entry-thumb-single"  style="background-image:url(http://blogs.kcrw.com/music/wp-content/uploads/2017/07/toro-y-moi-grass-575x575.jpg);background-position:center center" data-img-large="http://blogs.kcrw.com/music/wp-content/uploads/2017/07/toro-y-moi-grass-1024x576.jpg" data-img-full="http://blogs.kcrw.com/music/wp-content/uploads/2017/07/toro-y-moi-grass.jpg"  data-called="52980" >
		
			<div class="entry-categories">
				<div class="entry-category-parent"><a href="http://blogs.kcrw.com/music/category/best-new-music/">Best New Music</a></div>			</div>
		</div>
		<div class="entry-header-wrap">
			<h1 class="entry-title">Music For Your Weekend</h1>			<div class="entry-categories-tablet">
				<div class="entry-category-parent"><a href="http://blogs.kcrw.com/music/category/best-new-music/">Best New Music</a></div>			</div>
									<div class="entry-meta">
				<span class="posted-on"><time class="entry-date published" datetime="2017-07-07T10:59:44+00:00">July 7, 2017</time></span>				<div class="byline">By <span class="author vcard"><a class="url fn n" href="http://blogs.kcrw.com/music/author/aaronbyrd/">Aaron Byrd</a></span>			<ul class="author-contact-links">
									<li class="author-twitter"><a href="http://twitter.com/@itsabyrd" target="_blank">@itsabyrd</a></li>
											</ul>
		</div>				<div id="share">
	<div class="addthis_toolbox" addthis:url="http://blogs.kcrw.com/music/2017/07/music-for-your-weekend-16/" addthis:title="Music For Your Weekend">
		<a class="addthis_button_facebook view-1">
			<img src="http://blogs.kcrw.com/music/wp-content/themes/kcrw-triplicity/images/addthis_placeholder.gif"/>
		</a>
		<a class="addthis_button_twitter view-1">
			<img src="http://blogs.kcrw.com/music/wp-content/themes/kcrw-triplicity/images/addthis_placeholder.gif"/>
		</a>
		<a class="addthis_button_email view-2">
			<img src="http://blogs.kcrw.com/music/wp-content/themes/kcrw-triplicity/images/addthis_placeholder.gif"/>
		</a>
		<a class="copy-link view-2" data-clipboard-text="http://blogs.kcrw.com/music/2017/07/music-for-your-weekend-16/" id="share-link">
			<img src="http://blogs.kcrw.com/music/wp-content/themes/kcrw-triplicity/images/addthis_placeholder.gif"/>
		</a>
	</div>
</div>
			</div>
			<a href="http://blogs.kcrw.com/music/2017/07/show-218-new-and-noteworthy-releases/" rel="prev"></a>					</div>
	</header>

	<div id="desktop-header-container"></div>

	<div class="entry-content">
		<p>A few summer goodies featured on this week&#8217;s post. If can&#8217;t find anything you like here, you may need to check your pulse&#8230;turn &#8217;em up!</p>
<p><strong>Toro y Moi</strong> &#8211; &#8220;Girl Like You&#8221;</p>
<p>Chaz Bundick aka <strong>Toro y Moi</strong> has returned with the release of his fifth solo studio album today. In part, he says the album &#8220;was written to help him cope with an identity crisis caused by his growing popularity.&#8221; That might explain the futuristic yet nostalgic sound that defines <em>Boo Boo</em>. Bundick states influences for this album ranged from <strong>Travis Scott</strong> &amp; <strong>Frank Ocean</strong> to <strong>Daft Punk</strong> &amp; <strong>Oneohtrix Point Never</strong>. He says, &#8220;I recognized that the common thread between these artists was their attention to a feeling of space or lack thereof.&#8221; I think this is a pretty accurate description of the production throughout the full length. A great example of this is the single &#8220;Girl Like You.&#8221;</p>
<p><iframe width="800" height="450" src="https://www.youtube.com/embed/Fg7r4kQUbPw?feature=oembed" frameborder="0" allowfullscreen></iframe></p>
<p><strong>Duckwrth</strong> &#8211; &#8220;Boy&#8221;</p>
<p><strong>Duckwrth</strong> is such an interesting artist and thus, a breath of fresh air. The South Central L.A. based Duckwrth describes himself as &#8220;ugly,&#8221; which by the way alludes to his 2016 release, <em>I&#8217;m Uugly</em>. However, he doesn&#8217;t mean it in the way you might think. It&#8217;s not at all about being unattractive in a vain sense, rather an unabashed acceptance of deep appreciation of all the unconventional qualities that make him unique. This dedication to individual expression comes through in both Duck&#8217;s sense of fashion and his music. Case in point, his latest single &#8220;Boy&#8221; which is my most recent obsession! In it, Duck challenges the gender norms by allowing himself to be the &#8220;boy sleeping in a bed of roses&#8221; who &#8220;plants flowers on a hill&#8221;; while also referring to his lover as both a boy and a girl. In fact, Duckwrth says, &#8220;This song is for the rebels, the tomboys, the emotional dues, skater girls, the ones who say F*** Social Constructs. This is for you.&#8221; I told you he is an interesting cat. Even if his heightened social awareness doesn&#8217;t interest you, sonically you&#8217;ll still love &#8220;Boy.&#8221; It just sounds so damn good!</p>
<p><iframe width="800" height="400" scrolling="no" frameborder="no" src="https://w.soundcloud.com/player/?visual=true&#038;url=https%3A%2F%2Fapi.soundcloud.com%2Ftracks%2F330893725&#038;show_artwork=true&#038;maxwidth=800&#038;maxheight=1000"></iframe></p>
<p><strong>Joey Bada$$</strong> &#8211; &#8220;500 Benz&#8221;, &#8220;Too Lit&#8221; &amp; &#8220;Love Is Only A Feeling&#8221;</p>
<p>The 22 yr old Brooklyn rapper has established himself in the upper echelon of contemporary MCs with the success of his second LP, <em>ALL-AMERIKKKAN BADA$$$</em>. An album which has received several spins by KCRW DJs. Even though the album came out early April, on the 4th of July he tweeted (then quickly deleted) a promise of some new music for his fans. Then yesterday (July 6), less than three months after the release of AAB, Joey kept his word and dropped not one, not two but THREE new tracks. &#8220;500 Benz&#8221;, &#8220;Too Lit&#8221; and &#8220;Love Is Only a Feeling&#8221;&#8230; all of which are produced by long time collaborator <strong>Static Selektah</strong>. All three are very different both production and content wise. Enjoy, but beware the first two are NSFW.</p>
<p><iframe src="https://w.soundcloud.com/player/?url=https%3A//api.soundcloud.com/tracks/331588980&amp;color=ff5500&amp;auto_play=false&amp;hide_related=false&amp;show_comments=true&amp;show_user=true&amp;show_reposts=false" width="100%" height="166" frameborder="no" scrolling="no"></iframe></p>
<p><iframe src="https://w.soundcloud.com/player/?url=https%3A//api.soundcloud.com/tracks/331588237&amp;color=ff5500&amp;auto_play=false&amp;hide_related=false&amp;show_comments=true&amp;show_user=true&amp;show_reposts=false" width="100%" height="166" frameborder="no" scrolling="no"></iframe></p>
<p><iframe src="https://w.soundcloud.com/player/?url=https%3A//api.soundcloud.com/tracks/331585341&amp;color=ff5500&amp;auto_play=false&amp;hide_related=false&amp;show_comments=true&amp;show_user=true&amp;show_reposts=false" width="100%" height="166" frameborder="no" scrolling="no"></iframe></p>
			</div>
</article>

			
	<nav class="navigation post-navigation" role="navigation">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="http://blogs.kcrw.com/music/2017/07/show-218-new-and-noteworthy-releases/" rel="prev">Previous Post</a></div></div>
	</nav>
					<div class="related-posts" data-related-ids="46343, 52312, 46339, 52676, 44023, 50628, 49233, 44799, 45102, 39955">
			<h2>Related Stories</h2>
			<ul class="thumb-listing">
									
<li>
	<article id="post-52676" class="post-52676 post type-post status-publish format-standard has-post-thumbnail hentry category-best-new-music">
		<div class="entry-thumb">
			<a href="http://blogs.kcrw.com/music/2017/06/music-for-your-weekend-15/">
				<img width="575"height="575"src="http://blogs.kcrw.com/music/wp-content/uploads/2017/06/nvdes-575x575.jpg"class="attachment-thumbnail wp-post-image"alt="">			</a>
			<div class="entry-category">
				<a href="http://blogs.kcrw.com/music/category/best-new-music/">Best New Music</a>			</div>
		</div>
		<h3 class="entry-title"><a href="http://blogs.kcrw.com/music/2017/06/music-for-your-weekend-15/" rel="bookmark">Music For Your Weekend</a></h3>		<span class="posted-on"><time class="entry-date published" datetime="2017-06-23T11:33:38+00:00">June 23, 2017</time></span><span class="byline"> By <span class="author vcard"><a class="url fn n" href="http://blogs.kcrw.com/music/author/aaronbyrd/">Aaron Byrd</a></span></span>	</article>
</li>									
<li>
	<article id="post-52312" class="post-52312 post type-post status-publish format-standard has-post-thumbnail hentry category-todays-top-tune">
		<div class="entry-thumb">
			<a href="http://blogs.kcrw.com/music/2017/06/week-ahead-todays-top-tune-6-12-6-16-17/">
				<img width="575"height="575"src="http://blogs.kcrw.com/music/wp-content/uploads/2017/06/ttt-featured-06-12-17-575x575.jpg"class="attachment-thumbnail wp-post-image"alt="Today's Top Tune">			</a>
			<div class="entry-category">
				<a href="http://blogs.kcrw.com/music/category/todays-top-tune/">Today's Top Tune</a>			</div>
		</div>
		<h3 class="entry-title"><a href="http://blogs.kcrw.com/music/2017/06/week-ahead-todays-top-tune-6-12-6-16-17/" rel="bookmark">A Week Ahead: Today&#8217;s Top Tune 6.12 &#8211; 6.16.17</a></h3>		<span class="posted-on"><time class="entry-date published" datetime="2017-06-12T11:56:51+00:00">June 12, 2017</time></span><span class="byline"> By <span class="author vcard"><a class="url fn n" href="http://blogs.kcrw.com/music/author/arianamorgenstern/">Ariana Morgenstern</a></span></span>	</article>
</li>									
<li>
	<article id="post-50628" class="post-50628 post type-post status-publish format-standard has-post-thumbnail hentry category-best-new-music">
		<div class="entry-thumb">
			<a href="http://blogs.kcrw.com/music/2017/04/music-for-your-weekend-8/">
				<img width="575"height="575"src="http://blogs.kcrw.com/music/wp-content/uploads/2017/04/marcos_Garcia_photo_ManishGosalia-575x575.jpg"class="attachment-thumbnail wp-post-image"alt="">			</a>
			<div class="entry-category">
				<a href="http://blogs.kcrw.com/music/category/best-new-music/">Best New Music</a>			</div>
		</div>
		<h3 class="entry-title"><a href="http://blogs.kcrw.com/music/2017/04/music-for-your-weekend-8/" rel="bookmark">Music For Your Weekend</a></h3>		<span class="posted-on"><time class="entry-date published" datetime="2017-04-14T09:30:27+00:00">April 14, 2017</time></span><span class="byline"> By <span class="author vcard"><a class="url fn n" href="http://blogs.kcrw.com/music/author/aaronbyrd/">Aaron Byrd</a></span></span>	</article>
</li>									
<li>
	<article id="post-49233" class="post-49233 post type-post status-publish format-standard has-post-thumbnail hentry category-best-new-music">
		<div class="entry-thumb">
			<a href="http://blogs.kcrw.com/music/2017/02/new-music-ride/">
				<img width="575"height="575"src="http://blogs.kcrw.com/music/wp-content/uploads/2017/02/Ride_2015_Saint_Andrews_Hall_Detroit_MI-575x575.jpg"class="attachment-thumbnail wp-post-image"alt="">			</a>
			<div class="entry-category">
				<a href="http://blogs.kcrw.com/music/category/best-new-music/">Best New Music</a>			</div>
		</div>
		<h3 class="entry-title"><a href="http://blogs.kcrw.com/music/2017/02/new-music-ride/" rel="bookmark">New Music from Ride</a></h3>		<span class="posted-on"><time class="entry-date published" datetime="2017-02-28T13:57:58+00:00">February 28, 2017</time></span><span class="byline"> By <span class="author vcard"><a class="url fn n" href="http://blogs.kcrw.com/music/author/marionhodges/">Marion Hodges</a></span></span>	</article>
</li>							</ul>
			<div class="more-stories-button">
				<a href="#" id="more-related">See More Stories</a>
			</div>
		</div>
	

			
<div id="disqus-container">
	</div>
		
		</main>
	</div>


<div id="secondary" class="widget-area widget-area-footer" role="complementary">
		<div class="widget-area-footer-wrap">
		<aside id="text-19" class="widget widget_text"><h2 class="widget-title">More KCRW</h2>			<div class="textwidget"><ul>
<li><a href="http://www.kcrw.com">Visit KCRW.com</a></li>
<li><a href="http://www.kcrw.com/about/kcrw-mobile-applications">Download apps</a></li>
<li><a href="http://www.kcrw.com/about/contact">About / Contact</a></li>
<li><a href="http://www.kcrw.com/join">Donate</a></li>
</ul></div>
		</aside>	</div>
</div>

	</div><!-- #content -->

	<footer id="colophon" class="site-footer" role="contentinfo">
		<div class="site-info">
			&copy; 2017 KCRW All Rights Reserved
		</div><!-- .site-info -->
	</footer><!-- #colophon -->
</div><!-- #page -->

<div id="pum-52503" class="pum pum-overlay pum-theme-50399 popmake-overlay pum-overlay-disabled auto_open click_open" data-popmake="{&quot;id&quot;:52503,&quot;slug&quot;:&quot;music-newsletter&quot;,&quot;theme_id&quot;:50399,&quot;cookies&quot;:[{&quot;event&quot;:&quot;on_popup_close&quot;,&quot;settings&quot;:{&quot;name&quot;:&quot;pum-52503&quot;,&quot;key&quot;:&quot;&quot;,&quot;time&quot;:&quot;1 week&quot;,&quot;path&quot;:1}}],&quot;triggers&quot;:[{&quot;type&quot;:&quot;auto_open&quot;,&quot;settings&quot;:{&quot;delay&quot;:&quot;3000&quot;,&quot;cookie&quot;:{&quot;name&quot;:[&quot;pum-52503&quot;]}}},{&quot;type&quot;:&quot;click_open&quot;,&quot;settings&quot;:{&quot;extra_selectors&quot;:&quot;&quot;,&quot;cookie&quot;:{&quot;name&quot;:null}}}],&quot;mobile_disabled&quot;:true,&quot;tablet_disabled&quot;:null,&quot;meta&quot;:{&quot;display&quot;:{&quot;size&quot;:&quot;custom&quot;,&quot;responsive_min_width&quot;:&quot;&quot;,&quot;responsive_max_width&quot;:&quot;&quot;,&quot;custom_width&quot;:&quot;300&quot;,&quot;custom_height&quot;:&quot;250&quot;,&quot;overlay_disabled&quot;:&quot;1&quot;,&quot;animation_type&quot;:&quot;fade&quot;,&quot;animation_speed&quot;:&quot;350&quot;,&quot;animation_origin&quot;:&quot;center top&quot;,&quot;position_fixed&quot;:&quot;1&quot;,&quot;position_bottom&quot;:&quot;0&quot;,&quot;location&quot;:&quot;right bottom&quot;,&quot;position_right&quot;:&quot;0&quot;,&quot;position_top&quot;:&quot;100&quot;,&quot;position_left&quot;:&quot;0&quot;,&quot;overlay_zindex&quot;:&quot;1999999998&quot;,&quot;zindex&quot;:&quot;1999999999&quot;,&quot;responsive_min_width_unit&quot;:&quot;px&quot;,&quot;responsive_max_width_unit&quot;:&quot;px&quot;,&quot;custom_width_unit&quot;:&quot;px&quot;,&quot;custom_height_unit&quot;:&quot;px&quot;},&quot;close&quot;:{&quot;text&quot;:&quot;X&quot;,&quot;button_delay&quot;:&quot;0&quot;},&quot;click_open&quot;:{&quot;extra_selectors&quot;:&quot;&quot;}}}" role="dialog" aria-hidden="true" >

	<div id="popmake-52503" class="pum-container popmake theme-50399 size-custom pum-position-fixed">

				

				

		

				<div class="pum-content popmake-content">
			<p><a href="http://kcrw.co/2stCTlo"><img src="http://blogs.kcrw.com/music/wp-content/uploads/2017/06/newsletter2017-music-insider.jpg" alt="Music Insider Newsletter" /></a></p>
		</div>


				

				            <button type="button" class="pum-close popmake-close" aria-label="Close">
			X            </button>
		
	</div>

</div>
        <script type="text/javascript">
        // <![CDATA[
        var disqus_shortname = 'kcrwmusicblog';
        (function () {
            var nodes = document.getElementsByTagName('span');
            for (var i = 0, url; i < nodes.length; i++) {
                if (nodes[i].className.indexOf('dsq-postid') != -1 && nodes[i].parentNode.tagName == 'A') {
                    nodes[i].parentNode.setAttribute('data-disqus-identifier', nodes[i].getAttribute('data-dsqidentifier'));
                    url = nodes[i].parentNode.href.split('#', 1);
                    if (url.length == 1) { url = url[0]; }
                    else { url = url[1]; }
                    nodes[i].parentNode.href = url + '#disqus_thread';
                }
            }
            var s = document.createElement('script');
            s.async = true;
            s.type = 'text/javascript';
            s.src = '//' + disqus_shortname + '.disqus.com/count.js';
            (document.getElementsByTagName('HEAD')[0] || document.getElementsByTagName('BODY')[0]).appendChild(s);
        }());
        // ]]>
        </script>
        <script data-cfasync="false" type="text/javascript">
var addthis_config = {"data_track_clickback":true,"data_ga_property":"UA-404580-2","data_ga_social":true,"ui_language":"en","ui_atversion":300,"ignore_server_config":true};
var addthis_share = {"url_transforms":{"shorten":{"twitter":"bitly"}},"shorteners":{"bitly":{}}};
</script>
                <!-- AddThis Settings Begin -->
                <script data-cfasync="false" type="text/javascript">
                    var addthis_product = "wpp-5.3.5";
                    var wp_product_version = "wpp-5.3.5";
                    var wp_blog_version = "4.8";
                    var addthis_plugin_info = {"info_status":"enabled","cms_name":"WordPress","plugin_name":"Share Buttons by AddThis","plugin_version":"5.3.5","anonymous_profile_id":"wp-1350870f12d45bd94b474da50e3b6135","plugin_mode":"WordPress","select_prefs":{"addthis_per_post_enabled":true,"addthis_above_enabled":true,"addthis_below_enabled":false,"addthis_sidebar_enabled":false,"addthis_mobile_toolbar_enabled":false,"addthis_above_showon_home":false,"addthis_below_showon_home":true,"addthis_above_showon_pages":false,"addthis_below_showon_pages":true,"addthis_above_showon_categories":false,"addthis_below_showon_categories":true,"addthis_above_showon_archives":false,"addthis_below_showon_archives":true,"addthis_above_showon_posts":false,"addthis_above_showon_excerpts":false,"addthis_below_showon_posts":true,"addthis_below_showon_excerpts":true,"addthis_sidebar_showon_home":true,"addthis_sidebar_showon_posts":true,"addthis_sidebar_showon_pages":true,"addthis_sidebar_showon_archives":true,"addthis_sidebar_showon_categories":true,"addthis_mobile_toolbar_showon_home":true,"addthis_mobile_toolbar_showon_posts":true,"addthis_mobile_toolbar_showon_pages":true,"addthis_mobile_toolbar_showon_archives":true,"addthis_mobile_toolbar_showon_categories":true,"sharing_enabled_on_post_via_metabox":true},"page_info":{"template":"posts","post_type":""}};
                    if (typeof(addthis_config) == "undefined") {
                        var addthis_config = {"data_track_clickback":true,"data_ga_property":"UA-404580-2","data_ga_social":true,"ui_language":"en","ui_atversion":300,"ignore_server_config":true};
                    }
                    if (typeof(addthis_share) == "undefined") {
                        var addthis_share = {"url_transforms":{"shorten":{"twitter":"bitly"}},"shorteners":{"bitly":{}}};
                    }
                    if (typeof(addthis_layers) == "undefined") {
                        var addthis_layers = {};
                    }
                </script>
                <script
                    data-cfasync="false"
                    type="text/javascript"
                    src="//s7.addthis.com/js/300/addthis_widget.js#pubid=kcrw "
                    async="async"
                >
                </script>
                <script data-cfasync="false" type="text/javascript">
                    (function() {
                        var at_interval = setInterval(function () {
                            if(window.addthis) {
                                clearInterval(at_interval);
                                addthis.layers(addthis_layers);
                            }
                        },1000)
                    }());
                </script>
                <link rel='stylesheet' id='addthis_output-css'  href='http://blogs.kcrw.com/music/wp-content/plugins/addthis/css/output.css?ver=4.8' type='text/css' media='all' />
<script type='text/javascript' src='http://blogs.kcrw.com/music/wp-content/plugins/kcrw-blog-toolset/assets/js/full-width.js?ver=1.0'></script>
<script type='text/javascript' src='http://blogs.kcrw.com/music/wp-content/themes/kcrw-triplicity/js/clipboard.min.js?ver=1.5.5'></script>
<script type='text/javascript' src='http://blogs.kcrw.com/music/wp-content/themes/kcrw-triplicity/js/owl.carousel.min.js?ver=1.3.3'></script>
<script type='text/javascript' src='http://blogs.kcrw.com/music/wp-content/themes/kcrw-triplicity/js/jquery.fitvids.js?ver=1.1'></script>
<script type='text/javascript' src='http://blogs.kcrw.com/music/wp-includes/js/imagesloaded.min.js?ver=3.2.0'></script>
<script type='text/javascript' src='http://blogs.kcrw.com/music/wp-includes/js/masonry.min.js?ver=3.3.2'></script>
<script type='text/javascript' src='http://blogs.kcrw.com/music/wp-includes/js/jquery/jquery.masonry.min.js?ver=3.1.2b'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var triplicity = {"ajaxurl":"https:\/\/blogs.kcrw.com\/music\/wp-admin\/admin-ajax.php","query_vars":"{\"page\":\"\",\"year\":\"2017\",\"monthnum\":\"07\",\"name\":\"music-for-your-weekend-16\"}","is_single":"1","is_category":"","categories":"[2782,10074]"};
/* ]]> */
</script>
<script type='text/javascript' src='http://blogs.kcrw.com/music/wp-content/themes/kcrw-triplicity/js/kcrw.js?ver=1.2'></script>
<script type='text/javascript' src='http://blogs.kcrw.com/music/wp-content/themes/musicblog/js/music.js?ver=1.5'></script>
<script type='text/javascript' src='http://blogs.kcrw.com/music/wp-content/themes/kcrw-triplicity/js/navigation.js?ver=20120206'></script>
<script type='text/javascript' src='http://blogs.kcrw.com/music/wp-content/themes/kcrw-triplicity/js/skip-link-focus-fix.js?ver=20130115'></script>
<script type='text/javascript' src='http://blogs.kcrw.com/music/wp-content/plugins/popup-maker/assets/js/mobile-detect.min.js?ver=1.3.3'></script>
<script type='text/javascript' src='http://blogs.kcrw.com/music/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://blogs.kcrw.com/music/wp-includes/js/jquery/ui/position.min.js?ver=1.11.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pum_vars = {"ajaxurl":"https:\/\/blogs.kcrw.com\/music\/wp-admin\/admin-ajax.php","restapi":"http:\/\/blogs.kcrw.com\/music\/wp-json\/pum\/v1","rest_nonce":null,"default_theme":"50399","debug_mode":"","disable_open_tracking":""};
var pum_debug_vars = {"debug_mode_enabled":"Popup Maker Debug Mode Enabled","debug_started_at":"Debug started at:","debug_more_info":"For more information on how to use this information visit http:\/\/docs.wppopupmaker.com\/?utm_medium=js-debug-info&utm_campaign=ContextualHelp&utm_source=browser-console&utm_content=more-info","global_info":"Global Information","localized_vars":"Localized variables","popups_initializing":"Popups Initializing","popups_initialized":"Popups Initialized","single_popup_label":"Popup: #","theme_id":"Theme ID: ","label_method_call":"Method Call:","label_method_args":"Method Arguments:","label_popup_settings":"Settings","label_triggers":"Triggers","label_cookies":"Cookies","label_delay":"Delay:","label_conditions":"Conditions","label_cookie":"Cookie:","label_settings":"Settings:","label_selector":"Selector:","label_mobile_disabled":"Mobile Disabled:","label_tablet_disabled":"Tablet Disabled:","label_display_settings":"Display Settings:","label_close_settings":"Close Settings:","label_event_before_open":"Event: Before Open","label_event_after_open":"Event: After Open","label_event_open_prevented":"Event: Open Prevented","label_event_setup_close":"Event: Setup Close","label_event_close_prevented":"Event: Close Prevented","label_event_before_close":"Event: Before Close","label_event_after_close":"Event: After Close","label_event_before_reposition":"Event: Before Reposition","label_event_after_reposition":"Event: After Reposition","label_event_checking_condition":"Event: Checking Condition","triggers":{"click_open":{"name":"Click Open","modal_title":"Click Trigger Settings","settings_column":"<strong>Extra Selectors<\/strong>: {{data.extra_selectors}}"},"auto_open":{"name":"Auto Open","modal_title":"Auto Open Settings","settings_column":"<strong>Delay<\/strong>: {{data.delay}}"}},"cookies":{"on_popup_open":{"name":"On Popup Open","modal_title":"On Popup Open Settings"},"on_popup_close":{"name":"On Popup Close","modal_title":"On Popup Close Settings"},"manual":{"name":"Manual JavaScript","modal_title":"Click Trigger Settings"}}};
var ajaxurl = "https:\/\/blogs.kcrw.com\/music\/wp-admin\/admin-ajax.php";
var popmake_default_theme = "50399";
/* ]]> */
</script>
<script type='text/javascript' src='http://blogs.kcrw.com/music/wp-content/plugins/popup-maker/assets/js/site.min.js?defer&#038;ver=1.6.3' defer='defer'></script>
<script type='text/javascript' src='http://blogs.kcrw.com/music/wp-includes/js/wp-embed.min.js?ver=4.8'></script>
<!--wp_footer-->

<!-- Disable AddThis URL tracking code -->
<script type="text/javascript">
var addthis_config = addthis_config||{};
  addthis_config.data_track_addressbar = false;
</script>

<!-- Open E24 mini-player -->
<script type="text/javascript">
	jQuery(window).load(function () {
			jQuery('#menu-item-50140 a').click( function(e) {
	        e.preventDefault();
					window.open("https://www.kcrw.com/embed-player?api_url=https%3A//www.kcrw.com/now_playing.json%3Fchannel%3Dkcrwmusic&autoplay=true", "embed-player", "width=750,height=175,resizable=false,directories=no,titlebar=no,toolbar=no,location=no,status=no,menubar=no,scrollbars=no");
			    return false; } );
		});
</script>


</body>
</html>
